Welcome to Wivenhoe Forum 2.2

edited December 2016 in Forum Feedback
Old v2.1 thread is here

Welcome, everyone, to a new dawn: v2.2

This is the latest and most secure version of Vanilla's forum software. You can read the full release notes here.

Hopefully everything will run smoothly and you won't notice most of the changes and security fixes day-to-day, but there are a couple of things that I'd like to draw your attention to:

New editor!
We're now running Vanilla's new Advanced Editor, which should mean a much smoother posting experience. This should be a lot less clunky than the old editor. Please do post in here if you find any bugs, or experience issues (especially on mobile). As always though, please follow these guidelines when doing so.

Drafts!
Never lose that tirade again. Your posts will automatically save themselves as drafts as you're writing, so that torrent of abuse/helpful comment will always be waiting for you, even if you something goes wrong.

Quotes!
That moment we've all been waiting for! No more confusing @ symbols, you can now just click the 'quote' button under a user's post to be taken straight to the editor and write your response underneath theirs. The old @ function still works, if you so wish.

File uploads!
These are now done from within the editor itself. You can even drag and drop images straight into the post editor. Wow!

If you do encounter any bugs or issues, please post them in this thread. It is vitally important that you provide the following information to help me fix it:

  • Operating System (including version)
  • Browser (including version)
  • A link to the page affected (if applicable)
  • A screenshot of the problem (if applicable or you deem it necessary)
  • Details on how to replicate the problem (if applicable)

Thanks

Comments

  • The number of "visits" on my profile page has stopped going up since the new v2.2 started.
    Has the number of times we visit been dropped in this new system?
  • I was looking at the cycle path thread and inadvertently brushed over the new 'Quote' thing.  Although I did not want to make a comment just then this has resulted in a 'Quote' being accidentally embedded in the comments box and I cannot remove it.  Is there some way to delete this non existent comment or will it stay there forever so that if at some point I do wish to make a comment the 'quote' will appear before it as though I am commenting on it which I will not be - if you see what I mean.  I couldn't find a delete option?  Best - Pat

    PS I don't find the quote option very helpful personally.  I can see why you've added it because of thread swamping but I find it confusing.
  • Should have said I'm using an iPad Air iOS 9.2 I think. Browser chrome.
  • Hi @queenie, you should be able to remove the quote box by tapping in the editor at a point beyond the quote box, then tap the delete key as usual.

    Scrolling on the right side of the screen should also avoid the problem, but it's a habit to get into!

    As you say, it'll take a little getting used to but hopefully it'll mean less confusion in thread conversations.
  • Well I looked for the edit box but couldn't find it. Used to be obvious - I've frequently used it but now can't see it?
  • Doesn't the edit box only come up when you've posted a comment as it did just now in my previous post.  I haven't posted the comment box with the quote in it.  Maybe I could delete it then if I posted it first?
  • edited November 2015
    queenie said:
    Doesn't the edit box only come up when you've posted a comment as it did just now in my previous post.  I haven't posted the comment box with the quote in it.  Maybe I could delete it then if I posted it first?
    You can delete it before you post.

    Edits can be made using the cogwheel icon as per always.
  • But the cogwheel isn't there until you've posted.  There's just a diagonal two arrows.  The cog wheel only appears when you've posted.
  • edited November 2015
    @queenie this is getting a lot more complicated than it needs to be:

    image
  • On my computer the 'Quote: is at the end of every post, Including the ones on here
  • As it should be in 2.2
  • Mike I deleted it as you suggested (think I did try this before now I come to think of it) and it disappeared.  I thought that was it but when I came out of the thread and then went back into it just to check the quote had returned.
  • It was saved as a draft?
    Try deleting any drafts you may have.
  • There is no option to delete the draft that I can see other than the manual option suggested by Mike above which as I said I tried but although the comment disappeared so it looked like the problem was fixed, after I had left the thread and later returned the quote had returned.  I'm wondering if no one has any other solutions that I should just post the nonexistent comment with the accidental quote and then the edit function will appear and I should be able to delete it?
  • No that didn't work either.  Although the edit option appears there is no option to delete.  You can manually delete the quote but it reappears.  I do think this needs a fix.
  • Feel free to submit a support ticket @queenie.
  • Have finally got rid of it.  Deleted as suggested by Mike (again!).  Then typed in a comment that I didn't particularly want to make and posted it.  This time the quote disappeared and only my comment appeared.  Thanks for your assistance in helping me work this out.  Don't you think it would be useful to have a delete comment option on the edit menu though or a delete draft option.

    i won't be using the quote function again in a hurry!
  • queenie said:
    Have finally got rid of it.  Deleted as suggested by Mike (again!).  Then typed in a comment that I didn't particularly want to make and posted it.  This time the quote disappeared and only my comment appeared.  Thanks for your assistance in helping me work this out.  Don't you think it would be useful to have a delete comment option on the edit menu though or a delete draft option.

    i won't be using the quote function again in a hurry!
    Sounds like it was an auto saved draft that wasn't clearing itself properly. Glad to hear you've got it fixed!
  • @Mike_ I had played around with the above and just found that that experiment was still sitting in my drafts, so yeah, looks like the auto-save function.
  • It's just happened to me too ... I have a saved, half-typed comment that will not lie down and die!
  • @Savvy if you look at your drafts somewhere on the right hand side of the screen and there's a number after it, click on drafts and delete any you see, that should get rid of it.
  • Got it! Thanks very much for that Marika, I should have spotted the menu options myself. That auto-save sure is superfast though. Maybe we can turn the volume down a little?
  • I've not updated this for a while - the current number of registered users: 1,902.

    We're averaging around 5,500 page impressions per day.

    Many thanks for the support, and ta to the patient Mod team.
Sign In or Register to comment.